Is this TPS or stepper motor? or something else altogether

kenne

Turbocharged
Joined
Sep 3, 2016
Messages
556
Location
Gold Coast, Australia
Ride
05 Rocket iii Rat
So my bike when i'm riding my bike it is excellent but lately once i take it past 3k in rev's it decides to stay there like cruise control.Somtime t even increases rev's with no hand on the throttle. It is a 2006 classic, Ramair, three into one exhaust. secondaries are removed running ECU tune ending in 28. I have hooked it up to ECU tune and TPS is Green and no error code come up. If its the stepper motor are they a closed unit or can it be pulled apart and cleaned maybe as they are 300 plus bucks here. I have wd40'ed the bejeezus out of all surrounding throttle springs,cables etc. any ideas would be great as it can get a bit hairy going into twisties with the rev's so high.
 

kenne

Turbocharged
Thread starter
Joined
Sep 3, 2016
Messages
556
Location
Gold Coast, Australia
Ride
05 Rocket iii Rat
sorry more info,
Once I start the bike it goes through the initial gauge sweep idles at about 1200 then drops to about 800 to 850 with no dramas there. Also if I give it a rev it does take awhile to throttle back.
 
Last edited:

kenne

Turbocharged
Thread starter
Joined
Sep 3, 2016
Messages
556
Location
Gold Coast, Australia
Ride
05 Rocket iii Rat
ahh copy Gents new TPS will be ordered asap thanks gent's, just a quick question why does it come up green in tune ECU?
 

motolink

Nitrous
Joined
Sep 11, 2010
Messages
1,431
Location
Brisbane South, Australia
Ride
2011 Roadster and 2001 Bonneville
Kennedy, if you are stuck I carry one that I took of my 2011 Roadster and replace dit with a new one but was not the problem, I carry it as a spare now but you are welcome to use until your new one arrives.
 

warp9.9

Pocałuj mnie w dupę
Joined
Jun 10, 2007
Messages
11,335
Location
Forest City Illinois
Ride
07 Rocket
ahh copy Gents new TPS will be ordered asap thanks gent's, just a quick question why does it come up green in tune ECU?
According to the Tune ecu manual the 3 stage light is a connection indicator red not connected, orange connecting, green connected. Not sure why you think it has something to do with the TPS ? This is in section 3.2
 
Last edited:

kenne

Turbocharged
Thread starter
Joined
Sep 3, 2016
Messages
556
Location
Gold Coast, Australia
Ride
05 Rocket iii Rat
yeah cheers Moto, just called the dealer to get a price for new TPS, and they tell me there is a recall on my bike for high idle so hopefully they might change it out that will be a win.
 

kenne

Turbocharged
Thread starter
Joined
Sep 3, 2016
Messages
556
Location
Gold Coast, Australia
Ride
05 Rocket iii Rat
when i run Tune ECU the connection is on the right and it scrolls through that exact connection as you mentioned, in the bottom left of the screen there is the TPS spot that comes up green i would only assume that it would mean that the TPS is good, but we all know what assuming is.....
 

warp9.9

Pocałuj mnie w dupę
Joined
Jun 10, 2007
Messages
11,335
Location
Forest City Illinois
Ride
07 Rocket
when i run Tune ECU the connection is on the right and it scrolls through that exact connection as you mentioned, in the bottom left of the screen there is the TPS spot that comes up green i would only assume that it would mean that the TPS is good, but we all know what assuming is.....
I see what you mean and cannot find anything about itin the manual. It could be utilized with the sageman or one of the other ecu's and not the Keihin ecu. I have my suspicions but neither have to do with your problem which is the tps is loosing track of its position and thus all of a sudden sends a wrong voltage to the ecu and it makes the stepper motor bump the idle up.
 
Top