Stepper motor regulation problems

RIII Forever

.040 Over
Joined
Apr 27, 2014
Messages
56
Location
Italia, Milano
Ride
Rocket 3 Roadster MY 16, Street triple 675
Hello everyone, I have a problem with the idle on cold start, the bike is at about 1300 rpm and I basically have to pull the idle butterfly back by hand near the stepper motor to get it regularized, otherwise it takes several minutes to get regular.

I cleaned the primary TPS sensor (blue already updated the bike is MY 16) made several ISCV reset tests but I notice that I have problems moving 0.60 -> 0.72, in practice setting 0.60 it only goes up to about 0.68 and adjusting the screw of the stepper motor up to beyond the thread and failing to adjust to 0.72.


I think my problem is the clearance adjustment on the cam which is not at 0.5mm

Does anyone know how to do this adjustment?

A thousand thanks
 

TURBO200R4

stand up straight and grab the world by the a$$
Joined
Jan 24, 2013
Messages
8,269
Location
TUCSON AZ
Ride
07 rocket III classic
First spray wd40 or other cleaner around the return springs on the throttle rod/plates the do a few wide open throttles and let it fly shut.
Pull rubber away from stepper motor and spray cleaner into stepper motor do a few key on and off pl
Look at the stepper motor as two different adjustments
1st adjustment
Throttle adjust at closed throttle
Done with tuneecu. 062
Or stepper motor removed closed throttle. 062 (set tps)
2nd adjustment
Key on stepper motor engaged adjust the end of the stepper motor to .074.
Hth. Herman
 

RIII Forever

.040 Over
Joined
Apr 27, 2014
Messages
56
Location
Italia, Milano
Ride
Rocket 3 Roadster MY 16, Street triple 675
First spray wd40 or other cleaner around the return springs on the throttle rod/plates the do a few wide open throttles and let it fly shut.
Pull rubber away from stepper motor and spray cleaner into stepper motor do a few key on and off pl
Look at the stepper motor as two different adjustments
1st adjustment
Throttle adjust at closed throttle
Done with tuneecu. 062
Or stepper motor removed closed throttle. 062 (set tps)
2nd adjustment
Key on stepper motor engaged adjust the end of the stepper motor to .074.
Hth. Herman
thank you very much Herman, however for the adjustment of the thickness 0.5 mm how do you do it?
 

Attachments

  • 4CA8866B-9CEB-40B7-8B98-CE2648039CBB.jpeg
    4CA8866B-9CEB-40B7-8B98-CE2648039CBB.jpeg
    101.5 KB · Views: 14

warp9.9

Pocałuj mnie w dupę
Joined
Jun 10, 2007
Messages
11,398
Location
Forest City Illinois
Ride
07 Rocket
The .5 mm gap is just a preset gap when you are installing a stepper motor. Not when one is already on the bike. You just need to do the full ISCV. But first listen to Herman and clean clean, clean. Sound to me like your throttle it sticking and not closing which is why you can reach down there and close the throttle plates by hand.
Hope this helps. Sorry to butt in Herman.
 

RIII Forever

.040 Over
Joined
Apr 27, 2014
Messages
56
Location
Italia, Milano
Ride
Rocket 3 Roadster MY 16, Street triple 675
The .5 mm gap is just a preset gap when you are installing a stepper motor. Not when one is already on the bike. You just need to do the full ISCV. But first listen to Herman and clean clean, clean. Sound to me like your throttle it sticking and not closing which is why you can reach down there and close the throttle plates by hand.
Hope this helps. Sorry to butt in Herman.
Thanks warp9.9,
here maybe the problem is here, with the engine and ignition off, my accelerator goes against the stepper motor and the 0.5 mm thickness gauge does not pass, not even the 0.25mm one!

to install the stepper motor at 0.5 do I have to do it with the engine and ignition off with the adjustment of the nut?
 
Last edited:

TURBO200R4

stand up straight and grab the world by the a$$
Joined
Jan 24, 2013
Messages
8,269
Location
TUCSON AZ
Ride
07 rocket III classic
Thanks warp for helping out
Just my opinion
Forget about the .5mm setting
I think that the. 5mm is for like if you came to my shop and ask to do a quick check of the stepper motor i would grab a .5mm gauge and try and if it was close i would say it is real close to being correct.
However from what you said i think you have the adjustment off.
Are you using tuneecu?
If not what or how are you doing it?
 

RIII Forever

.040 Over
Joined
Apr 27, 2014
Messages
56
Location
Italia, Milano
Ride
Rocket 3 Roadster MY 16, Street triple 675
Thanks warp for helping out
Just my opinion
Forget about the .5mm setting
I think that the. 5mm is for like if you came to my shop and ask to do a quick check of the stepper motor i would grab a .5mm gauge and try and if it was close i would say it is real close to being correct.
However from what you said i think you have the adjustment off.
Are you using tuneecu?
If not what or how are you doing it?
yes yes I'm using Tuneecu!

this happens to me:

ISCV reset start
- I wait for the stepper motor to close completely and septum 0.60

- I double click, the motor swings between 0.60 and 0.68, I try to adjust it using the screw on the stepper motor but I can't get it to go to 0.72 as the thread is finished!

- I double click and wait for it to complete the reset

Redoing the procedure again to check the settings if they are left, I find myself with the first pass which is 0.64 and the second 0.69/0.70

What can it be ?

the bike has the lambda probe disabled, ramair and carpenter sidewinder exhaust, map and secondary open 100 %
 
Last edited:

TURBO200R4

stand up straight and grab the world by the a$$
Joined
Jan 24, 2013
Messages
8,269
Location
TUCSON AZ
Ride
07 rocket III classic
yes yes I'm using Tuneecu!

this happens to me:

ISCV reset start
- I wait for the stepper motor to close completely and septum 0.60

- I double click, the motor swings between 0.60 and 0.68, I try to adjust it using the screw on the stepper motor but I can't get it to go to 0.72 as the thread is finished!

- I double click and wait for it to complete the reset

Redoing the procedure again to check the settings if they are left, I find myself with the first pass which is 0.64 and the second 0.69/0.70

What can it be ?

the bike has the lambda probe disabled, ramair and carpenter sidewinder exhaust, map and secondary open 100 %

I am going to guess that the stepper motor was adjusted out to far and not able to retract enough to let the throttle go to full closed.
What i would reccomend is turn that adjuster nut in about 5 turns in and
When doing the tuneecu make sure that you have clearance at the end of stepper motor.
I will say it is possible
For the throttle to be held tight and rpm be as high as 5000 rpm do to sticky parts where the cables attach.
So while the stepper motor is retracted make sure that the disc where the stepper shaft/adjuster nut touches will move about 1/16 of an inch.
Then set tps at .62 (not .60).
What year mc is it?
Can you remove air filter to see if throttle plates are closed?
 

warp9.9

Pocałuj mnie w dupę
Joined
Jun 10, 2007
Messages
11,398
Location
Forest City Illinois
Ride
07 Rocket
Thanks warp9.9,
here maybe the problem is here, with the engine and ignition off, my accelerator goes against the stepper motor and the 0.5 mm thickness gauge does not pass, not even the 0.25mm one!

to install the stepper motor at 0.5 do I have to do it with the engine and ignition off with the adjustment of the nut?
all ISCV voltage along with the TPS both primary and secondary are set with the engine switch on so everything is powered up but the engine is not running. You do not have to have power on when changing the stepper motor itself and presetting the .5 mm .
Of course if the throttle close is not the same. I can see after several starts things going out of whack with normal stepper operations especially when it self adapts to much. Can you imagine checking all these parameters water temp, outside air temp and pressure density at different altitudes when the throttle plates are not or in some lucky cases are repeating. It's not a CNC but it must have some type of ladder programing to the ECU. I hope I didn't butt in.
 
Top