busajack

Top Fuel
Joined
Jan 3, 2007
Messages
1,982
Location
Cheyenne
Dah

Dam you guys are fast..Waiting for Email from my dealer.To cheap to call them and they'er to cheap to have a toll free number.. Jack
 

Toystoretom

Living Legend
Joined
Feb 25, 2006
Messages
2,449
If it is about the idle issue...it only took two years :D. My "fix" about turning up the base idle predates this website (I posted it on T Rat originally) and that has been a year and a half approximately.

I wonder if this is the new "tune" that most have commented they loose some "punch" after loading???
 

Sidecar Flip

Living Legend
Joined
Jul 16, 2006
Messages
6,358
Location
20150 Mc Carty Rd. Deerfield, Michigan 49238
Tomo:

Mine runs fine so I'm not taking it anywhere near the dealer. We'll see after this trip though. 3500 miles plus should shake out any cobwebs.

Interestingly, this afternoon I went over all the bolts and fasteners because Gunshots said he lost a couple of capscrews that held the exhaust pipes to the bracket beside the rear wheel and I've read here that the heat shield hex capscrews loosen up. Well, everything was tight except the heat shield and radiator trim caps. I applied a little 271 Threadlocker and ran 'em back in. That should do it, I hope. I'll be bringing up the back in our trio with Carol in front of me. I hope she don't get wacky listening to my front discs tink all week.:eek:

Leaving tomorow about 1:00pm for E&C's. It's about 150 miles due east of here. The adventure begins.....:)
 

Similar threads

Top
AdBlock Detected

We get it, advertisements are annoying!

Ad-blocking software does a great job at blocking ads, but it also blocks some useful and important features of R3Owners. For the best possible site experience please take a moment to disable your AdBlocker for R3Owners.Net.

I've Disabled AdBlock