Engine rebuild gone west

bebsy

Finicky
Joined
Mar 18, 2017
Messages
254
Location
Pattya Thailand
Ride
2006 Triumph R3
Just had a 2005 engine rebuild for a friend's bike after throwing a valve replaced with a new head and all the dressings complete new oil system new oil pressure sensor and more now this is the ball ache question, when I started it up idled fine oil light went out but when the engine started to warm up the light came on at idle and goes off at 1200rpm and stays off till it drops back to idle, its the same everytime couple of sleepless nights going through the obvious but nothing worked, at present I've got the old oil sensor and modifying it to suit a pressure adapter, has anyone got any thoughts on anything I've missed

Cheers🍻
 

Gregger

Top Fuel
Joined
Nov 2, 2013
Messages
1,884
Location
Timmins, Ontario
Ride
2012 Rocket Roadster
I can't remember who it was but after they had their engine apart, they had oil pressure problems right away. They pulled the sump, inspected the screens which were plugged with lint from the cloths used to wipe down parts. How hard is it to pull the sump and check those suction screens?
 
Last edited:

bebsy

Finicky
Thread starter
Joined
Mar 18, 2017
Messages
254
Location
Pattya Thailand
Ride
2006 Triumph R3
I can't remember who it was but after they had their engine apart, they had oil pressure problems right away. They pulled the pump, inspected the screens and which were plugged with lint from the cloths used to wipe down parts. How hard is it to pull the sump and check those suction screens?
Complete engine was totally dismantled and all casings powder coated which is another factor I should have mentioned, never thought of rechecking the screens cheers although they are new at least its a start of breaking the motor down again😫
 

R-III-R Turbo

Mine is the biggest :)
Joined
Oct 12, 2010
Messages
1,758
Location
Ireland
Ride
2.5L Stroker Rocket III, Hayabusa
Hey finally got to greet the man himself 🤝 your clips on YouTube have been a great help in the past,

To answer your question both pumps and all else required was replaced

Glad you enjoyed them.
Sounds like something is not right in the oil pressure circuit. The oil pressure around idle is low enough anyway at the best of times.
The oil pressure test will confirm if it is indeed low pressure (and not a faulty sensor/sensor circuit issue), and the necessity to start disassembling the engine again :(

Was there a lube issue previously, maybe related to why the engine had to be taken apart?
Or did the valve let go due to some other issue.
 

bebsy

Finicky
Thread starter
Joined
Mar 18, 2017
Messages
254
Location
Pattya Thailand
Ride
2006 Triumph R3
I'll try and keep it short the same time this happened I was busy replacing cam chain and clutch on my own so he ended up taking it to a T dealer that was over 1yr ago its sat there I went down initially to take a look the head and piston was totally trashed the stem of the valve had punctured the piston about 3 times from what I saw, I don't know the reason why this happened, they replaced everything and put it all back together and had this low oil issue, my mate said he never had this problem before... he works away fortunately and told them to do what needs to be done so they opened it up again replacing the entire lube system, and hey presto the light appears again they have not returned his emails ect and T have contacted me for help a few times so I'm down there doing the mediation thing trying to resolve the problem it's like when they took it apart they didn't look for a reason why it happened and again with the the oil system they just replaced it all at a very costly expense so I don't have any past information other than it's all new now, let me see what numbers come up when checking the oil pressure,.
Let me add it was knocking its head off so this wk I reshimmed every pot that were either double or over the required tolerance and they quizzed me about the stepper motor buzzing all the time it was completely tightened back its runs ok now other than the annoying red light... Can't believe I'm saying that I've always been attracted to red lights🤠
 
Last edited:

Idaho Red Rocket 3

Living Legend
Joined
Nov 22, 2008
Messages
5,064
Location
Nampa, Idaho
Ride
2006 R3 Standard Bagger w/Fairing
I know this is simple and may not be the answer, but take a look at the engine idle RPM. If it is 850 or lower try raising it with TuneECU to 925 or so. We all did this a long time ago as we were informed from PowerTripp before he retired that the at idle oil pressure was way to low at the stock idle speed.
 

Gerald

Supercharged
Joined
Dec 14, 2018
Messages
370
Location
Lou. Ky
Ride
05 Rocket 3
I'll try and keep it short the same time this happened I was busy replacing cam chain and clutch on my own so he ended up taking it to a T dealer that was over 1yr ago its sat there I went down initially to take a look the head and piston was totally trashed the stem of the valve had punctured the piston about 3 times from what I saw, I don't know the reason why this happened, they replaced everything and put it all back together and had this low oil issue, my mate said he never had this problem before... he works away fortunately and told them to do what needs to be done so they opened it up again replacing the entire lube system, and hey presto the light appears again they have not returned his emails ect and T have contacted me for help a few times so I'm down there doing the mediation thing trying to resolve the problem it's like when they took it apart they didn't look for a reason why and again with the the oil system just replaced it at a very costly expense so I don't have any past information other than it's all new now, let me see what numbers come up when checking the oil pressure,.
Let me add it was knocking its head off so this wk I reshimmed every pot that were either double or over the required tolerance and they quizzed me about the stepper motor buzzing all the time it was completely tightened back its runs ok now other than the annoying red light... Can't believe I'm saying that I've always been attracted to red lights🤠
I thought you were making pieces to hook an oil pressure gauge to read actual oil pressure. This is only way to know what is happening, without this, you're just wasting effort and time.
 
Top
AdBlock Detected

We get it, advertisements are annoying!

Ad-blocking software does a great job at blocking ads, but it also blocks some useful and important features of R3Owners. For the best possible site experience please take a moment to disable your AdBlocker for R3Owners.Net.

I've Disabled AdBlock