Transmission issue?

Adriano

.020 Over
Joined
Dec 11, 2020
Messages
46
Location
Toronto - Ontario - Canada
Ride
2014 Rocket 3 Touring
So I took my 2015 R3T out for a spin and everything was nice and dandy until I came back home after an hour or so of light cruising. I am a new owner and the thing still scares me enough to not abuse it. :)
As I was pulling on my driveway, I was in first gear and was about to maneuver so I can get it into the garage. Once I released the clutch slowly, the gear did not engage. I almost dropped the bike. I put it in neutral and then first again. Same thing, the gear would not engage.. same thing throughout all gears. I can hear the "clunk" noise but the bike is not going anywhere, it's not in gear. The linkage looks fine, I can see the clutch cable lifting the lever as I squeeze the clutch...is this something anyone experienced?
 

idk

Living Legend
Joined
May 16, 2008
Messages
5,382
Location
Maryland
Ride
Royal Enfield Bullet
Sounds like a detent spring to me i if the clutch is adjusted correctly. How many miles do you have on it?
 

Adriano

.020 Over
Thread starter
Joined
Dec 11, 2020
Messages
46
Location
Toronto - Ontario - Canada
Ride
2014 Rocket 3 Touring
Sounds like a detent spring to me i if the clutch is adjusted correctly. How many miles do you have on it?
Idk, you mentioning "clutch adjustment" made me think. I tinkered a bit with the clutch cable adjustment at the hand lever (the dial thingies). The clutch now seems to engage. Is it possible something slipped? I mean it was fine when I took it out. The issue occurred only when I got on my driveway.
 

Attachments

  • 16175772457024103516317231823588.jpg
    16175772457024103516317231823588.jpg
    112.8 KB · Views: 12

idk

Living Legend
Joined
May 16, 2008
Messages
5,382
Location
Maryland
Ride
Royal Enfield Bullet
Keep an eye on it. If it keeps needing adjustment then either an end is coming off the cable or something is worn in the lifter mechanism. Probably.
 

Adriano

.020 Over
Thread starter
Joined
Dec 11, 2020
Messages
46
Location
Toronto - Ontario - Canada
Ride
2014 Rocket 3 Touring
Also, the dots are ligning up in the attached pic
Keep an eye on it. If it keeps needing adjustment then either an end is coming off the cable or something is worn in the lifter mechanism. Probably.
Thanks idk. I'll take it for a spin tomorrow and hopefully I won't need to call roadside assistance 😁
 

Attachments

  • 16175774245028420410805847100364.jpg
    16175774245028420410805847100364.jpg
    101.7 KB · Views: 13

Kevin frazier

Widowmaker!
Joined
Dec 22, 2018
Messages
5,087
Location
Nashville
Ride
2008 Triumph rocket 3 touring
Idk, you mentioning "clutch adjustment" made me think. I tinkered a bit with the clutch cable adjustment at the hand lever (the dial thingies). The clutch now seems to engage. Is it possible something slipped? I mean it was fine when I took it out. The issue occurred only when I got on my driveway.
Can you pull on the sheath at that knurl away from lever, as you’re pulling on it can you take a picture of how far it seperates from the stop its at now. That doesn’t look right
 

Attachments

  • D886498A-FD88-4D76-9776-00D7476DDD9F.jpeg
    D886498A-FD88-4D76-9776-00D7476DDD9F.jpeg
    74.8 KB · Views: 7
Top
AdBlock Detected

We get it, advertisements are annoying!

Ad-blocking software does a great job at blocking ads, but it also blocks some useful and important features of R3Owners. For the best possible site experience please take a moment to disable your AdBlocker for R3Owners.Net.

I've Disabled AdBlock