Help: Signals, horn, brake gone

Discussion in 'General Tech Talk' started by TRath, Jul 6, 2019.

  1. TRath

    TRath Supercharged

    Country:
    Canada
    Messages:
    301
    Featured Threads:
    11
    Media:
    3
    Likes Received:
    385
    Trophy Points:
    73
    Location:
    Calgary, Alberta Canada
    Ride:
    2009 Rocket III Classic Custom
    Need help because I do not know electrical.

    My ignition finally crapped out on my 2009 Classic so I went with a keyless bypass. (Digital Guard Dog) Worked fine for a week then died. A friend and I traced it to a bad connector in the new kit and at the advice of DGD we cut the connector out and ran the wires directly. Bike starts again, but now I've lost signals, horn, and brake light.

    Would it just be a bad relay that would knock those out or is it more likely something in the ignition bypass wiring?

    (Also, yes, I know I should have just gone with a DeCosse setup, but it wasn't an option at the time.)
     
  2. idk

    idk Living Legend

    Messages:
    4,238
    Featured Threads:
    12
    Likes Received:
    5,038
    Trophy Points:
    823
    Location:
    Maryland
    Ride:
    Royal Enfield Bullet
    Check your fuses - it is the same fuse. Also, check the wiring diagram for the Classic which you can find in my signature. You may find that you cut that circuit out when you rewired it.

    P.S.
    DeCosse's system wires things correctly, my budget system combines the three circuits into one - but it is not hard to figure out how to wire the three circuits separately if you want to.
     
  3. TRath

    TRath Supercharged

    Country:
    Canada
    Messages:
    301
    Featured Threads:
    11
    Media:
    3
    Likes Received:
    385
    Trophy Points:
    73
    Location:
    Calgary, Alberta Canada
    Ride:
    2009 Rocket III Classic Custom
    Fuse looks fine. I did find that there is a burned tine in the large grey connector under the tank. I know 100% that this was fine before the system was installed (checked). Can anyone confirm what is going through that corner? I'm not confident in my reading of the wiring diagram, but if that is the block above the ignition and that prong is position 8 (circled), it might be the culprit. The question then would be if it can be fixed.

    (I leave for our RAT Raid on the 17th.) wiring.jpg

    64605946_601665843657646_5102024198180569088_n.jpg 64838135_2236874603240736_4331999590652837888_n.jpg
     
    Last edited: Jul 6, 2019
    Joesmoe likes this.
  4. DEcosse

    DEcosse If it's no Scottish it's CRAP!

    Messages:
    1,716
    Featured Threads:
    24
    Media:
    19
    Likes Received:
    2,246
    Trophy Points:
    323
    Location:
    Bay Area, CA
    Ride:
    Triumph Daytona (Custom)
    That is the high current Pin 1 that supplies the pole which switches to headlights and ignition

    It does NOT affect the Horns/Turns/Brake - the two wires on the connector for that are pins 6 & 8 (on the female side that is the Orange and the Orange/Green & Blue/Black) - check Fuse #4 for that before you get too deep into things.

    I have no idea how DGD wires it up because they only have two switched circuits, while the Rocket has three: Common 1 to Headlights/starter; common 1 to Ignition and common 2 to Brake/Turns/Horn. I don't how how they permutate that, possibly join the ignition and headlights together.
     
    Last edited by a moderator: Jul 7, 2019
  5. TRath

    TRath Supercharged

    Country:
    Canada
    Messages:
    301
    Featured Threads:
    11
    Media:
    3
    Likes Received:
    385
    Trophy Points:
    73
    Location:
    Calgary, Alberta Canada
    Ride:
    2009 Rocket III Classic Custom
    What are the odds it's something as simple as the flasher relay? (I'd probably have to order one to check.)
     
  6. DEcosse

    DEcosse If it's no Scottish it's CRAP!

    Messages:
    1,716
    Featured Threads:
    24
    Media:
    19
    Likes Received:
    2,246
    Trophy Points:
    323
    Location:
    Bay Area, CA
    Ride:
    Triumph Daytona (Custom)
    Extremely doubtful - I would say nil
     
  7. TRath

    TRath Supercharged

    Country:
    Canada
    Messages:
    301
    Featured Threads:
    11
    Media:
    3
    Likes Received:
    385
    Trophy Points:
    73
    Location:
    Calgary, Alberta Canada
    Ride:
    2009 Rocket III Classic Custom
    Fuse is fine, dropped 2 replacements in to test (just in case one of them was bad too) but still nothing.
    Supposed to be leaving for my 10th year at the Kootenay RAT Raid on the 17th and it's starting to look questionable unless DGD actually replies with a solution and doesn't ship it by turtle.
     
  8. TRath

    TRath Supercharged

    Country:
    Canada
    Messages:
    301
    Featured Threads:
    11
    Media:
    3
    Likes Received:
    385
    Trophy Points:
    73
    Location:
    Calgary, Alberta Canada
    Ride:
    2009 Rocket III Classic Custom
    Pulled all the wiring for the new ignition and found a bad connection. All is well on planet Roc again. Well, almost everything...
    [​IMG]
     
    Last edited: Jul 9, 2019
    Tripps, Grumpy Ole Codger and idk like this.
Loading...
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice