This should be simple, headlights don't work

Joesmoe

IMOKUR2
Staff member
Joined
Aug 3, 2014
Messages
5,206
Location
Fairfax, Virginia
Ride
Triumph: 2014 Rocket III Touring
The recommended connection for Eastern Beaver is to leave all the bike's wiring as is, and intercept the wires just before the headlights. The wires that were for power, are routed to the relay activation. New power wires are led to the battery with separate fuse.

Any trouble shooting should be same as any bike that year without the EB kit.
 

redtrek

.020 Over
Joined
Dec 7, 2011
Messages
40
Location
Casa Grande, AZ
Ride
2006 Rocket III Classic
I really appreciate it! It's 2-wire fused lead from the battery to the first relay, jumped from there to the second relay. I have 12VDC at both 4-prong relays. There is a yellow wire and a white wire, one to each of the relays, that comes from the wire harness. It looks like they are blue/red-stripe and blue/yellow-stripe coming off the wire harness. The other wires go from each relay to each headlight. I will take a couple pictures and post them as the next comment. I really appreciate the help! I'm supposed to ride escort for a military funeral a week from Monday, so I have until then to get it straightened out.
I was wrong. It's blue/red-stripe and blue/white-stripe.
 

Attachments

  • C5C0C9FD-2877-4EAD-875F-44101A01523D.jpeg
    C5C0C9FD-2877-4EAD-875F-44101A01523D.jpeg
    143.8 KB · Views: 7
  • 03555652-5877-47E4-8D3D-60C3F2B7F744.jpeg
    03555652-5877-47E4-8D3D-60C3F2B7F744.jpeg
    168.1 KB · Views: 7
  • 95B8D9AB-F317-481F-81C3-B68858A9F131.jpeg
    95B8D9AB-F317-481F-81C3-B68858A9F131.jpeg
    163.8 KB · Views: 7

redtrek

.020 Over
Joined
Dec 7, 2011
Messages
40
Location
Casa Grande, AZ
Ride
2006 Rocket III Classic
The recommended connection for Eastern Beaver is to leave all the bike's wiring as is, and intercept the wires just before the headlights. The wires that were for power, are routed to the relay activation. New power wires are led to the battery with separate fuse.

Any trouble shooting should be same as any bike that year without the EB kit.
The kit he sent me was for new wiring to the bulb sockets and brought power directly from the battery instead of the wire harness. It eliminated the British-required little parking marker lights. I haven't had an issue with it in 8 or 9 years. This just came up since I changed the starter relay.
 

redtrek

.020 Over
Joined
Dec 7, 2011
Messages
40
Location
Casa Grande, AZ
Ride
2006 Rocket III Classic
I was wrong. It's blue/red-stripe and blue/white-stripe.
The first picture shows the black & red wires from the battery to the first relay. The second picture shows the jumper from the first relay to the second one. The third picture shows the two wires coming from the wire harness; one goes to each relay.
 

TURBO200R4

stand up straight and grab the world by the a$$
Joined
Jan 24, 2013
Messages
6,128
Location
TUCSON AZ
Ride
07 rocket III classic
It is impossible to follow this on this phone. My computer is at my shop.
However will list a couple of things.
If u have removed the little parking bulb then the terminal will touch and blow fuses.
Can not comprehend the system
However bat wire should go to
Sorry to late in the day i am brain dead for now.
 

redtrek

.020 Over
Joined
Dec 7, 2011
Messages
40
Location
Casa Grande, AZ
Ride
2006 Rocket III Classic
It is impossible to follow this on this phone. My computer is at my shop.
However will list a couple of things.
If u have removed the little parking bulb then the terminal will touch and blow fuses.
Can not comprehend the system
However bat wire should go to
Sorry to late in the day i am brain dead for now.
If you're a fan of The Far Side, you might remember the little boy pushing on the door to the Midvale School for the Gifted, when the door is clearly marked "pull." That's me today. Remember how I changed out my starter relay a couple weeks ago? I didn't realize that I had pulled out a 5-pin Bosch and replaced it with a 4-pin. I was looking at the socket to make sure the leads were all secure, pulled out the new relay to make sure I had it seated correctly, and on went the lightbulb (in my head). I went to Autozone and picked up a 5-pin. Voíla! The lightbulbs went on (on the bike). I'm sorry for wasting everyone's time.

Also, the EB headlight kit had me disconnect the parking lights. The bulbs & sockets are still there.
 

Similar threads

Top
AdBlock Detected

We get it, advertisements are annoying!

Ad-blocking software does a great job at blocking ads, but it also blocks some useful and important features of R3Owners. For the best possible site experience please take a moment to disable your AdBlocker for R3Owners.Net.

I've Disabled AdBlock