Speedo trouble on Touring Model

cktire

.060 Over
Joined
Sep 13, 2007
Messages
141
Location
Frederick, MD
Ride
2005 Rocket III Standard
I have a 2008 R3 Touring model that I have had problems with the speedo. I have combed this site and seen others have had the same problem that I'm experiencing but I can't seem to find a solution.
I had my bike parked outside during a heavy rain storm. My speedo gauge filled up with water. I dried it out but the neutral light quit working. I tried to get the panel open as I could see the bad light but couldn't get to it. In the process I ruined the whole darn thing.
Went to Ebay and bought a a used speedo but the part number was wrong and it was for an ABS model. I didn't realize this until installed. The speedo, odometer, fuel gauge and turn signal canceling switch did not work. I returned the speedo and bought another correct used speedo. Installed it but still have the four functions not working. I've cleaned all the electrical connections. Triumph insists it's a plug and play part.
I guess my next step is to take it in to a dealer but they are all backed up for weeks.
Any suggestions would be welcomed. Willing to pay a tech for instructions.
Carl
 

cktire

.060 Over
Joined
Sep 13, 2007
Messages
141
Location
Frederick, MD
Ride
2005 Rocket III Standard
Find someone close to you with a working speedometer swap them and see what happens.
Good suggestion, I wish I had that option available. But since the functions were not there with the ABS speedo also I kinda think it's the bike. Pinwheel has a video of it working, so who knows.
Thank you,
 

cktire

.060 Over
Joined
Sep 13, 2007
Messages
141
Location
Frederick, MD
Ride
2005 Rocket III Standard
Read this thread
Speedometer and Ecm
Part # is T1290053
Thanks John,
I read that tread about the Fall Detection Switch fixing the problem. Pinwheel had a used one for $5.95 so I just went ahead and bought it. Not much to lose by trying. I did however check BikeBandit and they show a different part number. #T2502405. Pinwheel doesn't list the part number but it certainly looks the same, they show it coming off a Rocket Touring. I saw it and wanted to grab it, little to lose since I have two Rockets and one might go bad some day.
Many thanks,
 

barbagris

Mad Scientist
Joined
Aug 1, 2010
Messages
12,953
Location
On the verge of insanity
Ride
2009 R3-Standard - 1979 Guzzi V1000G5
Good suggestion, I wish I had that option available. But since the functions were not there with the ABS speedo also I kinda think it's the bike. Pinwheel has a video of it working, so who knows.
Thank you,
The speedo from a post 2010 bike WILL NOT WORK on a pre 2009 bike - EVER. Read here An R+D Thread - Different instruments.
 

cktire

.060 Over
Joined
Sep 13, 2007
Messages
141
Location
Frederick, MD
Ride
2005 Rocket III Standard
The speedo from a post 2010 bike WILL NOT WORK on a pre 2009 bike - EVER. Read here An R+D Thread - Different instruments.
Thank you for that information. I really have no desire to use an aftermarket setup. I'll check into the model year that my used speedo came off of. As I understand it the part number is the same for all non ABS models so, even if I got a new one it might not work. Frustrating, it should not be this hard!
 

barbagris

Mad Scientist
Joined
Aug 1, 2010
Messages
12,953
Location
On the verge of insanity
Ride
2009 R3-Standard - 1979 Guzzi V1000G5
Show us what you're trying to fit and we can identify it - if it is from a R3 Touring - it wont work on a "Standard" - Do you mean "Tourer"?
 
Top
AdBlock Detected

We get it, advertisements are annoying!

Ad-blocking software does a great job at blocking ads, but it also blocks some useful and important features of R3Owners. For the best possible site experience please take a moment to disable your AdBlocker for R3Owners.Net.

I've Disabled AdBlock