Gas gauge doesn't work

Frosty Rider

Turbocharged
Joined
Nov 24, 2016
Messages
579
Location
Toronto, Ontario, Canada
Ride
2010 Rocket III Touring, 2020 Rocket 3GT
Wow Sonny, this is great thanks.
If it's possible ould you do a video of how you take off odd float sender and how to install that ? The gas filter looks fairly easy to install?
Was there a reason you took gas tank completely off? I just hate to do that with a fresh paint job and scratch it being up side down . I would like just to lift tank in the up position.
Is there a reason to replace all nuts for bottom of gas pump? And not use the original ones?
Nice step bye step. Thanks I'm sure this will be good for others as well.
I haven't seen the bike yet, i'm at Finch and McCowan area, where are you at, and you know it is supposed to be partly cloudy and 18 on Sunday, just saying, where you riding Saturday, and we need to discuss re-designing the seat on my GT, it's not bad, could be better, I have the sport seat on it right now
 

canecorso

The custom seat man
Thread starter
Joined
Apr 12, 2015
Messages
1,138
Location
Toronto, Canada
Ride
2005 Triumph Rocket 3 Classic
I'm in Richmond Hill just North of Elgin Mills . Saturday not where we are riding, Sunday is a better day I could always meet up with you on Sunday but will need to be after 2:00pm
Or your welcome to join us Saturday.
There is some pictures of my bike under custom on just painted my bike,
If you want to check out. But looks so much better up close:)
 

canecorso

The custom seat man
Thread starter
Joined
Apr 12, 2015
Messages
1,138
Location
Toronto, Canada
Ride
2005 Triumph Rocket 3 Classic
Ok here is a question for you guys put your thinking cap on.
I went for ride on Saturday I put gas in it really fast hopeing it will loosen the float .
I turn my bike on and gas gauge went up to full and gas gauge came off, I was wow it's fixed :)
Then I was riding and as soon as I hit 35 miles the gauge dropped to empty and gas light came on.
And when I filled it has started to drip out of over flow again but now has stoped not filling it any higher then I usually do.
Ok what could be the reasons?
I was thinking if gas gauges goes up my sender should be good?
I was thinking could my float rod be bent the wrong way? So when it's filled it thinks it's over filled? But thinking that doesn't explain as soon as I hit 35 miles the gauge gas drops to empty and gas light comes on,
This is a mystery any ideas?
 

canecorso

The custom seat man
Thread starter
Joined
Apr 12, 2015
Messages
1,138
Location
Toronto, Canada
Ride
2005 Triumph Rocket 3 Classic
Started it up in neutral and gas light came on and engine light and gas gauge didn't move this time still on empty. And gas is still doing a bit from overflow tubes on bottom.
If its the sender my gas gauge wouldn't work at all? And why is gas dripping out of overflow gas tubs on bottom? Now I'm really confused.
Don't want to invest in a new sender and take tank apart when that might not be the problem:(
 

TURBO200R4

stand up straight and grab the world by the a$$
Joined
Jan 24, 2013
Messages
6,428
Location
TUCSON AZ
Ride
07 rocket III classic
I am trying to help u
There has been a problem with a few guys that had there clutch switch shorted and that cause a problem like u have.
Question
Can u start your rocket in nuetral with the clutch lever out/not pulled in?
 

canecorso

The custom seat man
Thread starter
Joined
Apr 12, 2015
Messages
1,138
Location
Toronto, Canada
Ride
2005 Triumph Rocket 3 Classic
Oh I get you now sorry I was pulling in clutch.
I got the keyless installed I push the bottom and need to pull in clutch to start it. Tried to do what you said and will not start with out pulley in clutch.
 

bebsy

Finicky
Joined
Mar 18, 2017
Messages
257
Location
Pattya Thailand
Ride
2006 Triumph R3
I had the same problem I renewed the clutch switch which played up occasionally that didn't fix it I replaced the sender which had been in a few battles over the years replacing filters and pump that didn't fix it either, turned a resister in the gauge had gone bad and unrepairable, keeping in mind it did work before I replaced the sender albeit faulty but consistent at least, check the gauge before you splash out, also if you manage to get a coat hanger in there and lift the float you can check the voltage on tune ecu which would give you and indication at least
 
Top