Danger! POWERBRONZE EXTENDED SCREEN

maurice

Nitrous
Thread starter
Joined
May 2, 2020
Messages
1,395
Location
Tucson,AZ
Ride
2020 R3 GT
For those that have the same screen and commented they will inspect more, THAT WONT HELP. My screws were tightend every 3 or for hwy rides, and the screen had no cracks.
Just sayin.
 

maurice

Nitrous
Thread starter
Joined
May 2, 2020
Messages
1,395
Location
Tucson,AZ
Ride
2020 R3 GT
Super glad you are unscathed. Wow. Could it be possible that a small, unnoticed chip or nick occurred at the edge of the windshield,or within a mounting hole, and a crack propagated from the damage? A rock or other jetsam, or even a packaging, storage or handling mishap? A materials scientist could look at the windscreen under a microscope and, within a few minutes, tell you where and why it cracked. Hang onto it, perhaps someone would be interested in doing the analysis. To be honest, the failure is statistically remote and I would not be afraid to put on a replacement...unless you have been struck by lightening thrice and paid for your Rocket with Lottery winnings:).
Thanks.
I noticed nothing unusual, cleaned it every week, screw tightening every 3rd hwy ride about.
I do have the broken lower piece. A very nice even break from one side to the other. Powerbronze might want it. Next week I may do the same ride and look for the bigger half. I remember about where it happened.
I had approached close to redline in 5th gear( don't know how fast that was, too busy looking at tach), and had just gone into 6 with full throttle then bang! Wonder what speed. Have to try red line in 5th to get an idea.
 

Attachments

  • 20220109_131514.jpg
    20220109_131514.jpg
    321.2 KB · Views: 11

Azisbest

Turbocharged
Joined
Oct 17, 2016
Messages
520
Location
Arizona
Ride
2020 GT
For those that have the same screen and commented they will inspect more, THAT WONT HELP. My screws were tightend every 3 or for hwy rides, and the screen had no cracks.
Just sayin.
I have never tightened mine again since I first installed it. Is there any chance you were over tightening? Just trying to think of possibilities.
 

maurice

Nitrous
Thread starter
Joined
May 2, 2020
Messages
1,395
Location
Tucson,AZ
Ride
2020 R3 GT
I have never tightened mine again since I first installed it. Is there any chance you were over tightening? Just trying to think of possibilities.
Don't think so cause I just snuged it up. I remember people having g problems cause they did not tighten.
And you never tighten, over 130 mph!
Thanks for the thought.
 

Azisbest

Turbocharged
Joined
Oct 17, 2016
Messages
520
Location
Arizona
Ride
2020 GT
Don't think so cause I just snuged it up. I remember people having g problems cause they did not tighten.
And you never tighten, over 130 mph!
Thanks for the thought.
Yea I have had it to max speed with no issues with the Powerbronze, but its entirely possible I have just been lucky. The hard plastic mounting bushings did fall apart on me at one point but Powerbronze replaced them on warranty. So I actually did remove and retighten the fixings on that occasion. I forgot about that. But the screens themselves have been fine. .
 

maurice

Nitrous
Thread starter
Joined
May 2, 2020
Messages
1,395
Location
Tucson,AZ
Ride
2020 R3 GT
Been mulling over the cause of the break. I did change the black spacers to the neoprene harder white ones. Wonder if they were too hard as the black ones had some "give". 🤔 just a thought.
Company said they are investigating the cause. Without the broken piece good luck with that.
 
Top