200 HP Chase Begins .... Now Completed 14 Months In. WooHoo !!

TURBO200R4

stand up straight and grab the world by the a$$
Joined
Jan 24, 2013
Messages
7,598
Location
TUCSON AZ
Ride
07 rocket III classic
Thanks @R-III-R Turbo. The extension wire you ask about is for the air flow sensor that goes in the RamAir filter.

Do you have any thoughts on the metal "ice sickles" on the crank position sensor ?

Just my opinion
I think u should pull the bottom cover and check the screens ect for more damage.

I went back through your threads trying to determine what your problem was.
Could u fill us in on what's happening
 

Idaho Red Rocket 3

Living Legend
Joined
Nov 22, 2008
Messages
5,314
Location
Nampa, Idaho
Ride
2006 R3 Standard Bagger w/Fairing
The problem is it wont run on all 3 cylinders. It runs very rich on cylinder 1 and cylinders 2 and 3 seem to be running very lean to not at all.

The screens were cleaned out when I first took the engine apart. They had all normal crap on them.
 

R-III-R Turbo

Mine is the biggest :)
Joined
Oct 12, 2010
Messages
1,904
Location
Ireland
Ride
2.5L Stroker Rocket III, Hayabusa
Thanks @R-III-R Turbo. The extension wire you ask about is for the air flow sensor that goes in the RamAir filter.

Do you have any thoughts on the metal "ice sickles" on the crank position sensor ?

Probably normal enough collection of some flakes from break in, If that was the first time the CPS was out.
Good it is cleaned now though.

So you're going to switch out the injectors with another set, ensure fully seated vac tubes and try run it?
 

TURBO200R4

stand up straight and grab the world by the a$$
Joined
Jan 24, 2013
Messages
7,598
Location
TUCSON AZ
Ride
07 rocket III classic
The problem is it wont run on all 3 cylinders. It runs very rich on cylinder 1 and cylinders 2 and 3 seem to be running very lean to not at all.

The screens were cleaned out when I first took the engine apart. They had all normal crap on them.

Have you tried to lube/clean all the return springs and wide open throttle then let fly closed several times
Make sure u have free play in the cable might put a little extra just till it idles correct.
Is the o2 sensor getting hot?
U could hook up three test lights to the outside (negative) side of the coils then to positive battery and watch to see if the the lights blink the same.
You could do the same with the injectors but u would have to have special probes to penetrate the wires.
Did u run compression check to make sure that the valve/ valves are not to tight?
 

TURBO200R4

stand up straight and grab the world by the a$$
Joined
Jan 24, 2013
Messages
7,598
Location
TUCSON AZ
Ride
07 rocket III classic
Have you tried to lube/clean all the return springs and wide open throttle then let fly closed several times
Make sure u have free play in the cable might put a little extra just till it idles correct.
Is the o2 sensor getting hot?
U could hook up three test lights to the outside (negative) side of the coils then to positive battery and watch to see if the the lights blink the same.
You could do the same with the injectors but u would have to have special probes to penetrate the wires.
Did u run compression check to make sure that the valve/ valves are not to tight?

Just dawned on me that I have never tried that on the injectors. Might be that they work very fast for a while during the intake process that u might just have a solid light and on exhaust the test light would b out.
 

TURBO200R4

stand up straight and grab the world by the a$$
Joined
Jan 24, 2013
Messages
7,598
Location
TUCSON AZ
Ride
07 rocket III classic

This is a great tool
But i was thinking of comparing the injectors while running on all 3 cylinders
 
Top