Bench testing the Primary TPS

motolink

Nitrous
Joined
Sep 11, 2010
Messages
1,431
Location
Brisbane South, Australia
Ride
2011 Roadster and 2001 Bonneville
For the past 18 months I have experienced some slight surging when cruising at around 2400rpm, the surging is worse when I engage the Cruise control, the higher the speed the worse it is, it feels like the throttle is going on and off. At first I thought it had something to do with the cruise control but after working with the guys from MCCruise and going through all the checks and adjustments the problem is still there.
I also notice when the bike is on its stand and I slowly turn the throttle to build up the revs I can see the tacho and revs moving around between between 1100 to 1300rpm then when the throttle reaches 1600rpm the revs take off to about 2400 rpm without me having turned the throttle. This happens with the stepper motor unplugged and with the cruise control disconnected.
Could this be a TPS issue, is there a bench testing procedure for the testing the TPS. Using Tune Ecu I don’t see any fluctuations in the TPS voltage when the throttle is turned from closed to full throttle.
 

motolink

Nitrous
Thread starter
Joined
Sep 11, 2010
Messages
1,431
Location
Brisbane South, Australia
Ride
2011 Roadster and 2001 Bonneville
I checked and cleaned all the electrical connections, the low tension coil wires, the earth connections and reloaded the tune. Only had a short test ride but it seems the surging was fixed, will have to do a a good ride today before I start celebrating.
 
Top