Plug and Go tire repair kit

HeR3tic

Living Legend
Joined
Nov 25, 2006
Messages
3,454
Location
Heart of Dixie (Alabama)
The Plug and Go tire repair kit uses some unique mushroom shaped plugs. After two failures to get the plug to press through the nozzle I lubed the third one up with some Pam cooking spray and it went in easily. The mushroom plugs have some sort of lubricant on them, in the packaging. But apparently insufficient. If your kit doesn't have a small bottle of light oil I suggest adding something. On the otherhand, don't forget the oil dip stick will get the necessary drops of oil to do the trick.
 

rusty

Turbocharged
Joined
Aug 23, 2006
Messages
735
Location
Northwest, MO.
Ride
2005 Rocket III
Great call on the oil from the dipstick HeRtic. Just what it would take to get that dang mushroom to slip through the hole in the carcass as well. I carry a plug kit in the truck which is the long fibered noodle type "and" a jar of Vasoline. If only Vasoline came in minature jars, that would help 'em slip right in.

Thanks for the tip R.

So, when all was said & done, did the mushroom plug do its job? I have the same kit but have not had to take evasive action with it. Information about the application please. Spme Captains seem to be uncertain about running the Rocket on a tire with a plug in it. I, on the other hand, have used plugs for so long it's second nature. No fear here, just lots of $$$$ saved over the years. Yes, I will use one on the bike tire too.

See ya.
 
Last edited:

HeR3tic

Living Legend
Thread starter
Joined
Nov 25, 2006
Messages
3,454
Location
Heart of Dixie (Alabama)
Yeah I've heard 'em; the reluctance to use plugs. That's advice for ya. Like I have $300 to have a week old tire replaced.:eek: I'll keep it under 145:D Just call me heretic.

Without adding the extra lube into the nozzle, there apparently wasn't enough resident on the plugs coming out of the package, the ram pressed through the first two plugs and demolished them. On the third attempt, with the cooking spray applied, the ram progress was sooo much easier and the effort to apply the ram was really minimal. If during the ramming process, using the allen wrench, the effort is huge you're probably encountering the same problem. Clean out the hole with the provided spiral rasping tool to the point where it will reasonably easily run in and out. Doing so will likely eliminate the "mallet" application.

The nozzle placement, on the instructions, is all the way to the hilt. A rubber mallet helped. With the plug now inserted and the tail end exposed by almost 1/2" I tugged on it modestly to seat the mushroom head against the inner wall. My next tire change with determine how effective that was.

There are certainly cheaper kit. My luck with using the string plugs with the hook type applicator has been a big fat 0. The Stop $ Go Plugger tool works for me. I didn't use the CO2 cartridges; I was at home with a compressor.
 
Last edited:

Paul Hyland

Turbocharged
Joined
Dec 29, 2006
Messages
983
Location
League City TX
Hey! Just a thought

Have not see this type with the mushroom plug, were did you get it. I like sidecar have always used the string type and have never had a problem. I just put one in my truck last week. I use lots of glue and it goes in with some effert.
Side note for those who don't like running with plugs and don't like replacing a week old tire, think about this. You can take the tire off and take it to a tire shop and have them plug it and patch it from the inside then you can put the tire back on. If done right it will last the life of the tire.
 

Darron

.040 Over
Joined
Mar 25, 2007
Messages
71
Location
Waco, TX
plugging a tire

Hi all,

Ever since the early '90's I have had tubeless tires on bikes. And when getting a flat, the dealer has always said, "replace the tire, it's safer". But being ultra frugal, (cheap), I began carrying on all my vehicles, including the bikes, a 12Volt air supply and rope type plugs.

IMO, the plugs, if done right, are just a safe as the internal patches. I also carry a tube of cleaner/emulsifier to lube the plugs with. Insert the plug about 2/3rds the way inside the tire leaving an inch or so sticking out. Cut off the external plug at about 1/4 to 1/2 inch and re inflate.

After sever flats on various vehicles, including motorcycles, I have NEVER had a problem. And have always run the tire until it was worn out. People have told me the plugs would eventually work loose, but have not found that to be true when using the cleaner/emulsifier, (which also seems to act as a glue).

This is just my experiences and someone may have better ideas or worse experiences.
 

Sidecar Flip

Living Legend
Joined
Jul 16, 2006
Messages
6,358
Location
20150 Mc Carty Rd. Deerfield, Michigan 49238
Have not see this type with the mushroom plug, were did you get it. I like sidecar have always used the string type and have never had a problem. I just put one in my truck last week. I use lots of glue and it goes in with some effert.
Side note for those who don't like running with plugs and don't like replacing a week old tire, think about this. You can take the tire off and take it to a tire shop and have them plug it and patch it from the inside then you can put the tire back on. If done right it will last the life of the tire.

You don't have to completely remove the tire. Just break the bead on one side and lever that side over the rim. Then put a flat patch over the hole on the inside. Remember to rough it up a little before you apply the patch. Mark the outside of the tire with (I use a paint pencil) so you'll know where the hole is. That's called a 'boot' That way, there is no need to re-balance or anything. Do it all the time. If, however, you get a puncture in the sidewall, the tire is junk no matter what.
 

Paul Hyland

Turbocharged
Joined
Dec 29, 2006
Messages
983
Location
League City TX
Darron

What do you use for an cleaner/emulsifier. I usally just ream the tire good and apply ALOT of glue. But I to have had no problems with the plugs.
 

Darron

.040 Over
Joined
Mar 25, 2007
Messages
71
Location
Waco, TX
cleaner/emulsifier

Paul,

That description is mine, not written on the tube. I order it from Mills Auto in Hubbard, TX.

I simply look at what it does, (clean the area it touches and softens the rubber), and named it. The last was "Camel" brand. Currently, I'm out of the stuff, as once the tube is opened, it drys quickly. The next time I have to go for an auto part, I'll see what's available and get more. Surely an auto store in your area can come up with something similar.
 
Top