Hello everyone I'm new here

gsieber

Standard Bore
Joined
Jul 29, 2021
Messages
3
Ride
2005 Triumph Rocket III
Hello, I just purchased a 2005 Rocket III a week ago and love it so far! In fact, i'm trying to talk my son into getting a rocket! I do hear a rattling noise which i've read can mean that it's a loose/worn cam chain tensioner. However, i don't hear the noise when the engine is running but the bike is not moving. Also, sometimes it seems like the rattling noise is coming from the rear of the bike but i just can't seem to pinpoint where it's coming from. I've checked to make sure all the heat shields are secure. Anyone have any suggestions on what it might be or what to check?

thanks, Greg
 

atomsplitter

Top Fuel
Joined
Nov 29, 2007
Messages
1,942
Location
Keller, TX
Ride
2017 T-120 Black, 2020 Bobber, 1998 Trophy 1200
Welcome to the forum. Does it have the stock intake plumbing or has it been given pods on the intake? If it has pods, you may be hearing the valve clatter (the intake snorkel hides that noise). If that's not it can you post a sound file of the noise?
 

gsieber

Standard Bore
Thread starter
Joined
Jul 29, 2021
Messages
3
Ride
2005 Triumph Rocket III
Welcome to the forum. Does it have the stock intake plumbing or has it been given pods on the intake? If it has pods, you may be hearing the valve clatter (the intake snorkel hides that noise). If that's not it can you post a sound file of the noise?
thanks for the reply atomsplitter! I do believe everything on the bike is stock. I'll try to get a sound file loaded soon, though i'm going on vacation for several days so it might a while till i can do that.
 

atomsplitter

Top Fuel
Joined
Nov 29, 2007
Messages
1,942
Location
Keller, TX
Ride
2017 T-120 Black, 2020 Bobber, 1998 Trophy 1200
thanks for the reply atomsplitter! I do believe everything on the bike is stock. I'll try to get a sound file loaded soon, though i'm going on vacation for several days so it might a while till i can do that.
Not a problem. Enjoy your time off (I'm retired so every day is a holiday...).
 

gsieber

Standard Bore
Thread starter
Joined
Jul 29, 2021
Messages
3
Ride
2005 Triumph Rocket III
Hello everyone!

Back from vacation. i decided to pull the sump pan to see if there is anything in the screens. Here is what i found. I took the screens to the local Triumph dealer and the mechanic said he though it was sand in the one on the right? Anyone have any idea what it might be? I'm going to clean them off, put in new oil, and then drive it for a couple hundred miles and check again to see if it's an existing problem, or if it might be something from a while back. the bike does have 43000 miles on it.
 

Attachments

  • thumbnail (1).jpg
    thumbnail (1).jpg
    264.7 KB · Views: 6
  • thumbnail.jpg
    thumbnail.jpg
    266.6 KB · Views: 6
Top