Got all me coolant hoses replaced today

Willtill

Nitrous
Joined
Aug 20, 2009
Messages
1,024
Location
Hanover, Maryland
Whelp.... since I'm On Call again (from work) and am not allowed to wander too far from my laptop... decided to flush and change my coolant, and replace all of my coolant hoses. Wasn't too bad replacing them.... a little tight with the inside water pump hose; as well as the top radiator hose.... coolant bypass wasn't a problem either... though my bike gleefully scraped off varying layers of skin from the back of my hands in doing all five hoses...:pullhairout: but best part is....

...no Leaks! :grin:
 

R-III-R Turbo

Mine is the biggest :)
Joined
Oct 12, 2010
Messages
1,535
Location
Ireland
Ride
2.5L Stroker Rocket III, 04 Hayabusa
so why were they replaced will?
mine have discolored since i got the bike

man it took me abot 5 minutes to type this poist. **** drinlk
 

Willtill

Nitrous
Joined
Aug 20, 2009
Messages
1,024
Location
Hanover, Maryland
Ha! :grin:

When I have to revise a post 5 times... I get off of the forum :alcy:


I had a very irritating issue with the upper radiator hose; where it attached to the outlet on the thermostat. It would always leak after the bike first got hot, and then stop for the duration of the ride. No matter how much I tightened it up; it would continue to leak at first startup.

Since the hoses were all 4 years old (and yes, mine discolored as well for some reason) I decided an ounce of prevention was worth a pound of cure.... and just opted to replace them all.... with new clamps as well.

This is also the second time I have flushed my coolant, and I am always finding little black particles and sand in it.
 

R-III-R Turbo

Mine is the biggest :)
Joined
Oct 12, 2010
Messages
1,535
Location
Ireland
Ride
2.5L Stroker Rocket III, 04 Hayabusa
well hopefully the leak will be fixed. nothing more annoying than a little problem that wont go away!

like the EBC pads in put in recently, they rattled on the front. i got new anti rattle springs and they still rattled. couldnt figure it out so i says feck that and put the stock nissins back in. still 3mm of pad on them. and they're legit. wasnt im[ressed by the EBCs i have to say. anyhooo. as you were
 

zimtuff

Nitrous
Joined
Dec 28, 2009
Messages
1,051
Location
Perth Western Australia
Ride
2008 Trimuph Rocket
Whelp.... since I'm On Call again (from work) and am not allowed to wander too far from my laptop... decided to flush and change my coolant, and replace all of my coolant hoses. Wasn't too bad replacing them.... a little tight with the inside water pump hose; as well as the top radiator hose.... coolant bypass wasn't a problem either... though my bike gleefully scraped off varying layers of skin from the back of my hands in doing all five hoses...:pullhairout: but best part is....

...no Leaks! :grin:
Since I got my bike it always used coolant ,not much,but more than it should.But I could never find the leak.
Some people on this forum seemed to believe it was normal ,but I wasnt happy with that.
When the water pump died,I decided to fix it once and for all.
New pump,hoses,clamps and radiator cap. Since then not a drop has had to be replaced,much happier.
 

Battersea

Turbocharged
Joined
Aug 28, 2011
Messages
673
Location
Devon - UK
............... like the EBC pads in put in recently, they rattled on the front. i got new anti rattle springs and they still rattled. couldnt figure it out so i says feck that and put the stock nissins back in. still 3mm of pad on them. and they're legit. wasnt im[ressed by the EBCs i have to say. anyhooo. as you were

Was going to use EBC but then got a tip from another forum, replace pre-Roadster with Roadster pads, they work better apparently.
 

Mitchcpc

Supercharged
Joined
Jul 1, 2007
Messages
263
Ha! :grin:

When I have to revise a post 5 times... I get off of the forum :alcy:


I had a very irritating issue with the upper radiator hose; where it attached to the outlet on the thermostat. It would always leak after the bike first got hot, and then stop for the duration of the ride. No matter how much I tightened it up; it would continue to leak at first startup.

Since the hoses were all 4 years old (and yes, mine discolored as well for some reason) I decided an ounce of prevention was worth a pound of cure.... and just opted to replace them all.... with new clamps as well.

This is also the second time I have flushed my coolant, and I am always finding little black particles and sand in it.
What coolant (brand/type) did you put back it?
 

R-III-R Turbo

Mine is the biggest :)
Joined
Oct 12, 2010
Messages
1,535
Location
Ireland
Ride
2.5L Stroker Rocket III, 04 Hayabusa
Was going to use EBC but then got a tip from another forum, replace pre-Roadster with Roadster pads, they work better apparently.
stock roadsters are nissin on the front, brembo on the rear.. you mean hook an '07 (for example) up with these?

i have to say the nissins have stronger bite than the EBCs and appear to be lasting longer than cheaper pads. only trouble they are hard to get and are expensive
 
Thread starter Similar threads Forum Replies Date
Jeremy COOLANT General Tech Talk 5
Darron1117 Found coolant leak? General Tech Talk 1
Darron1117 Coolant loss - where ? Why ? General Tech Talk 12
Wadejesu Coolant Temp 2.5 Litre Rockets 1
Darron1117 Coolant under bike General Tech Talk 14
Similar threads





Top
AdBlock Detected

We get it, advertisements are annoying!

Ad-blocking software does a great job at blocking ads, but it also blocks some useful and important features of R3Owners. For the best possible site experience please take a moment to disable your AdBlocker for R3Owners.Net.

I've Disabled AdBlock