Joseph James

.020 Over
Joined
May 29, 2016
Messages
25
Location
Dunnellon Florida
Ride
2000 Thunderbird, 1200 Daytona SE
My 2007 Rocket 3 developed a issue with the Power Commander 3 that was installed and tuned 12 years ago. Intermittently the bike would stall and run rich. I disconnected the CP 3 and reconnected the wiring harness but forgot to reconnect the O2 sensor. My bike has a K&N air filter, cat delete pipe and a Raask 3 into 2 slip ons. Disconnecting the P C resolved the problems and the bike runs just as good as it did with proper functioning PC. Is it ok to run it this way? There isn't any engine codes. Any ideas?

Thank you, Joe
 

TURBO200R4

stand up straight and grab the world by the a$$
Joined
Jan 24, 2013
Messages
6,264
Location
TUCSON AZ
Ride
07 rocket III classic
PC = power commander
did u hook up the o2 sensor?
does it have the CP o2 replacement bung (forget what it is called)?
i think that u should take it to a tuner.
 

Bull

.060 Over
Joined
Jan 18, 2017
Messages
101
Location
Saline, MI
Ride
2007 Rocket III Classic Tourer
I am having the exact same issue with my '07. hope someone has an answer.
 

Idaho Red Rocket 3

Living Legend
Joined
Nov 22, 2008
Messages
5,064
Location
Nampa, Idaho
Ride
2006 R3 Standard Bagger w/Fairing
You need a proper tune but there are several custom canned tunes on the TuneECU website. At least get one of those downloaded as your stock tune now is far too lean for any long term use. A dyno tune is best but one of these canned tunes is good enough for now.
 

Joseph James

.020 Over
Thread starter
Joined
May 29, 2016
Messages
25
Location
Dunnellon Florida
Ride
2000 Thunderbird, 1200 Daytona SE
PC = power commander
did u hook up the o2 sensor?
does it have the CP o2 replacement bung (forget what it is called)?
i think that u should take it to a tuner.
Nope. Figured if the ECM got a input from O2 sensor the bike would run to lean. No engine light so ECM is not missing the O2 sensor? No after market O2 gizmo. I read somewhere that a missing O2 sensor will make the fuel mixture rich. Maybe the mods I made have corrected the fuel mixture . I'm going to take my Rocket for a ride and check the color of the spark plugs.
 

Joseph James

.020 Over
Thread starter
Joined
May 29, 2016
Messages
25
Location
Dunnellon Florida
Ride
2000 Thunderbird, 1200 Daytona SE
I am having the exact same issue with my '07. hope someone has an answer.
I had a idle problem away back and resolved it by pouring a whole bottle of Lucas fuel system cleaner in a tank of gas. Eight bucks for 5.6 oz of stuff seemed expensive but it worked for me. Add the elixir take your bike for a short ride and let the bike sit for a day or two.
 

Bull

.060 Over
Joined
Jan 18, 2017
Messages
101
Location
Saline, MI
Ride
2007 Rocket III Classic Tourer
You need a proper tune but there are several custom canned tunes on the TuneECU website. At least get one of those downloaded as your stock tune now is far too lean for any long term use. A dyno tune is best but one of these canned tunes is good enough for now.
I had mine dyno’d and it worked well till this year. For example if you let it idle till warm it chokes and stalls, smells like it was running rich.
 

Joseph James

.020 Over
Thread starter
Joined
May 29, 2016
Messages
25
Location
Dunnellon Florida
Ride
2000 Thunderbird, 1200 Daytona SE
I had mine dyno’d and it worked well till this year. For example if you let it idle till warm it chokes and stalls, smells like it was running rich.
Sounds like dirty fuel injectors. The fuel injectors are designed to spray the gas as a fine mist and dirty ones spit the gas instead making the engine run rich as it warms up. I poured a whole bottle of Lucas fuel system cleaner in a tank of gas
 
Top
AdBlock Detected

We get it, advertisements are annoying!

Ad-blocking software does a great job at blocking ads, but it also blocks some useful and important features of R3Owners. For the best possible site experience please take a moment to disable your AdBlocker for R3Owners.Net.

I've Disabled AdBlock