rocket wont start

Discussion in 'General Tech Talk' started by daylkn, Dec 4, 2010.

  1. daylkn

    daylkn Standard Bore

    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    have big trouble with 2007 rocket bike shut down completly problem has been ongoing since before warranty ran out dealer cannot diagonos as when plugged into machinedoes not even recognize the bike any suggestions as bike is now out of warranty and dealer does not have a clue we do not have lemon protection in Australia so am on my own
  2. Molinoman

    Molinoman Turbocharged

    Country:
    United States
    Messages:
    2,753
    Likes Received:
    253
    Trophy Points:
    783
    Location:
    Molino, FL
    Rides:
    2014 Triumph Rocket III Touring
    I don't even know where to start with this one. Your dealer, I believe, if he couldn't diagnose it should have contacted Triumph directly and asked them what he should do. I would think at the very least something happened to the ECU/M and it probably needed to be replaced. This should have happened before the warranty expired if it was a known problem.

    I would check with your dealer and find out if he has any records of him attempting to fix it and have him check with Triumph of Austraila and see what the rep says to do.

    Triumph has allowed for many "out of warranty" repairs in the US...I would think that your bike would qualify for that kind of consideration...especially if the dealer has it documented.

    Good luck,

    Dennis

    5 dtg KAF (8 or 9 if I can help it...don't like being in KAF)
    10 dtg Dubai
    11 dtg London
    13 dtg Ace Motorcycle Cafe

    64 dtg Dubai
    65 dtg Home (Thunderbird time and, hopefully, R3T ordering time)
  3. tdragger

    tdragger Turbocharged

    Country:
    United States
    Messages:
    2,530
    Likes Received:
    518
    Trophy Points:
    813
    Location:
    Fredericksburg, VA
    First, welcome to the board. You will find this to be a valuable resource.

    Let's start with what you mean by "shutdown".

    Are you having troubles starting it? Is so, have the usual suspects been checked? clutch switch, sidestand switch, gear indicator, ignition switch (big source of problems on earlier models), kill switch. When you turn the key on, do the headlights come on?

    Have you checked the snugness of connections under the tank? on the starter? on the battery? (yeah, obvious but you would be surprised)

    Did the bike "shutdown" while riding?

    Do you have any indication that it is experiencing a major engine mechanical failure?

    I know that you are quite frustrated at the moment but if you can spend a little time describing the symptoms, there are a number of very experienced wrenches on this board that can probably help.
  4. HellFire

    HellFire Legend

    Messages:
    4,547
    Likes Received:
    338
    Trophy Points:
    583
    Sorry to knock your writing, but that run-on sentence doesn't do much to describe the trouble your having. Like Dragger said, there are many things in multiple systems that cause an even greater number of problems. You will have to be much more specific when trying to describe the symptoms for anyone to help. Please take your time and give us what happens, the conditions when it happens and anything you've done while you were having the problem. example: bike dies when turning left and restarts after it sits overnight.
    We need details. :)

    If you have dealer repair orders from when the bike was in warranty with your complaints documented but not repaired, Triumph is very good about taking care of owners out of warranty. You can always contact Triumph directly if your dealer is not able to fix the problem or wants to charge you for something you complained about while it was under warranty.
  5. daylkn

    daylkn Standard Bore

    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    Bike started..then shut down.
    Bike still turns over on starter motor..but will not fire up.
    Headlights come on.
    Clutch switch. side stand switch. lean over switch and engine management control have all been replaced ...acccording to dealer.
    Battery has been replaced and all connections checked
    No indication of major mecanical failure
    The bike is now at a second truimph dealer as the first one gave up .
    Any help will be greatly appreciated.
    My apologies for the run on sentence ( got the missus to type this one for me !:cool: )
  6. Gothlander

    Gothlander 321 GONE

    Country:
    Australia
    Messages:
    801
    Likes Received:
    314
    Trophy Points:
    163
    Location:
    Gold Coast Australia
    If the dealers diagnostic tool will not recognize the ECU then the problem is there. Maybe the ECU power relay is dodgy. The ignition should be looked at and the plug for signs of heat.

    PS whats your location?
  7. warp9.9

    warp9.9 Turbocharged

    Country:
    United States
    Messages:
    2,597
    Likes Received:
    1,191
    Trophy Points:
    813
    Location:
    Forest City Illinois
    Goth is on the right track I have heard of a few needing to have the ECU replaced, but only a few. Still its worth a try hopefully the dealer has one on the shelf. If not pinwall has a used one alot less then a new one. Of course two dealers just out of warrantee if you havven't overloaded it with electrical mods ( you don't have any Gig Pro **** do you?) Triumph should be all over this and send a ECU to try. What abou tthe gear indicator switch. has it been changed some of them were faulty also.
  8. tdragger

    tdragger Turbocharged

    Country:
    United States
    Messages:
    2,530
    Likes Received:
    518
    Trophy Points:
    813
    Location:
    Fredericksburg, VA
    It sounds like all the safety switches are functioning, otherwise it would not turn over. For some reason, it's just not firing up.

    Fuel?
    Air?
    Spark?

    Fuel - is the fuel pump cycling when the key is turned on? Are you getting any fuel smell in the throttle bodies? etc...

    Air? - are the MAP and IAT sensors functioning?

    Spark? - coils? connections to coils? etc...

    If all that checks out then it points to the ECU itself. Has the dealer tried a new download of the tune? Maybe the current one is corrupted.
  9. daylkn

    daylkn Standard Bore

    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    bike in dealer they have replaced all safety switches tacho speedo ECU all relays road speed sensor crank sensor coil pack ignition switch still no success they are running out of things to try even has Triumph Aust stumped
  10. xhdskip

    xhdskip Turbocharged

    Messages:
    5,732
    Likes Received:
    1,527
    Trophy Points:
    813
    Location:
    North of Tulsa, OKLAHOMA
    Get a new wiring harness from either Triumph or Pinwall (off ebay)
    Since they've replaced EVERYTHING else, go to the source, the wiring...
    Good luck and let us know the prognosis.
Similar Threads
Forum Title Date
General Tech Talk New battery and wont start Feb 8, 2013
General Tech Talk Damn bike wont start Feb 26, 2012
General Tech Talk my key wont open my gas cap Jan 11, 2014
General Tech Talk Litany of issues: no start, CEL, wiring possibly modified Jan 20, 2014
General Tech Talk Start of new Lighting r+d Jan 1, 2014

Share This Page